Browser sign-on and Notice acknowledgements — July 2026
Summary
Between 7 and 14 July 2026, an issue affected some workers using browser-based sign-on when a required Notice needed to be acknowledged.
The issue was limited to browser-based sign-on. Workers signing on through the BuildPass mobile app, including automatic sign-on, were not affected.
What happened
The browser sign-on flow made a request that was not suitable for worker access. Under certain conditions involving an existing Notice and its sign-on records, the request failed.
From 7–13 July, this meant workers may have completed a web sign-on without acknowledging a required Notice. On 14 July, affected workers were instead prevented from completing sign-on.
Not every browser sign-on or Notice was affected.
Resolution
We restored the worker-safe process on 14 July and confirmed that browser sign-on was operating normally again.
We then audited the affected records, contacted relevant customers and provided reports showing the Notices and workers requiring review. We also released a self-service tool allowing customers to contact affected workers and collect their acknowledgement.
What we are improving
We are committing significant engineering time to improving how we build, test and release changes to critical workflows such as sign-on, safety Notices and compliance processes.
This work includes:
- Stronger risk assessments and review requirements for changes involving compliance, permissions or sensitive data.
- Broader automated and manual testing of complete worker journeys, including multiple workers and different sign-on methods.
- More structured quality assurance
- Clearer error reporting, monitoring and alerts so failures can be detected and investigated sooner.
We have already added targeted regression coverage for this Notice acknowledgement flow. We are also adjusting our delivery practices to allow more time for testing and quality assurance when changes affect critical customer workflows.
Resolved
Browser sign-on and Notice acknowledgements — July 2026
Summary
Between 7 and 14 July 2026, an issue affected some workers using browser-based sign-on when a required Notice needed to be acknowledged.
The issue was limited to browser-based sign-on. Workers signing on through the BuildPass mobile app, including automatic sign-on, were not affected.
What happened
The browser sign-on flow made a request that was not suitable for worker access. Under certain conditions involving an existing Notice and its sign-on records, the request failed.
From 7–13 July, this meant workers may have completed a web sign-on without acknowledging a required Notice. On 14 July, affected workers were instead prevented from completing sign-on.
Not every browser sign-on or Notice was affected.
Resolution
We restored the worker-safe process on 14 July and confirmed that browser sign-on was operating normally again.
We then audited the affected records, contacted relevant customers and provided reports showing the Notices and workers requiring review. We also released a self-service tool allowing customers to contact affected workers and collect their acknowledgement.
What we are improving
We are committing significant engineering time to improving how we build, test and release changes to critical workflows such as sign-on, safety Notices and compliance processes.
This work includes:
- Stronger risk assessments and review requirements for changes involving compliance, permissions or sensitive data.
- Broader automated and manual testing of complete worker journeys, including multiple workers and different sign-on methods.
- More structured quality assurance
- Clearer error reporting, monitoring and alerts so failures can be detected and investigated sooner.
We have already added targeted regression coverage for this Notice acknowledgement flow. We are also adjusting our delivery practices to allow more time for testing and quality assurance when changes affect critical customer workflows.
Resolved
The fix has been deployed and browser sign-on is working as expected for projects with active Notices or pre-start requirements. This incident is now resolved, and we’ll continue monitoring.
Identified
Update: We have identified the cause of the sign-on issue. It affects browser sign-on for projects with active Notices or pre-start requirements. A fix has been prepared and is now being deployed. We will confirm once the deployment is complete and sign-on has been verified.
Investigating
We’re investigating reports that some users are unable to complete sign-on through the web app. The issue appears to affect projects where a Notice or pre-start acknowledgement is required as part of sign-on.
Our team is assessing the impact and working to identify the cause.